You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/fdutils/files/fdutils-5.5.20060227-r1-par...

19 lines
607 B

The Makefile implicit archive format ('Archives' in make.info) from, e.g.
'libfdutils.a($(LIBFILES))' does not support parallel operations. Convert to
parallel-safe structure.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
--- fdutils-5.5-20060227.orig/src/Makefile.in 2019-03-17 13:25:43.891918479 -0700
+++ fdutils-5.5-20060227/src/Makefile.in 2019-03-17 13:30:05.067424657 -0700
@@ -67,7 +67,7 @@
lex.%.c: %.lex
lex -P$* $<
-libfdutils.a: libfdutils.a($(LIBFILES))
- ranlib libfdutils.a
+libfdutils.a: $(LIBFILES)
+ ar rcs $@ $^
floppycontrol.o getfdprm setfdprm: /usr/include/linux/fd.h