You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-crypt/nasty/files/nasty-0.6-flags.patch

23 lines
468 B

--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,16 @@
VERSION=0.6
DEBUG=-g # -pg
-CFLAGS+=-Wall -O2 -DVERSION=\"${VERSION}\" $(DEBUG)
-LDFLAGS=-lgpgme $(DEBUG)
+CPPFLAGS+=-DVERSION=\"${VERSION}\" -D_FILE_OFFSET_BITS=64
+CFLAGS+=-Wall $(DEBUG) `gpgme-config --cflags`
+LIBS=`gpgme-config --libs`
OBJS=nasty.o
all: nasty
nasty: $(OBJS)
- $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o nasty
+ $(CC) $(LDFLAGS) $(OBJS) -o nasty $(LIBS)
install: nasty
cp nasty /usr/bin