You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emulation/libguestfs/files/1.24/0004_add_icoutils_configure...

58 lines
2.1 KiB

diff --git a/configure.ac b/configure.ac
--- a/configure.ac
+++ b/configure.ac
@@ -621,28 +621,36 @@
fi
dnl Check for netpbm programs (optional).
-AC_CHECK_PROGS([PBMTEXT],[pbmtext],[no])
-AC_CHECK_PROGS([PNMTOPNG],[pnmtopng],[no])
-AC_CHECK_PROGS([BMPTOPNM],[bmptopnm],[no])
-AC_CHECK_PROGS([PAMCUT],[pamcut],[no])
-if test "x$PBMTEXT" != "xno"; then
- AC_DEFINE_UNQUOTED([PBMTEXT],["$PBMTEXT"],[Name of pbmtext program.])
-fi
-if test "x$PNMTOPNG" != "xno"; then
- AC_DEFINE_UNQUOTED([PNMTOPNG],["$PNMTOPNG"],[Name of pnmtopng program.])
-fi
-if test "x$BMPTOPNM" != "xno"; then
- AC_DEFINE_UNQUOTED([BMPTOPNM],["$BMPTOPNM"],[Name of bmptopnm program.])
-fi
-if test "x$PAMCUT" != "xno"; then
- AC_DEFINE_UNQUOTED([PAMCUT],["$PAMCUT"],[Name of pamcut program.])
-fi
+AC_ARG_ENABLE([icoutils],
+ AS_HELP_STRING([with-icoutils], [ Enable ico and bmp icon file inspection]),
+ [enable_icoutils=no],
+ [enable_icoutils=yes])
+AS_IF([test "enable_icoutils" != "xno"],
+ [
+ AC_CHECK_PROGS([PBMTEXT],[pbmtext],[no])
+ AC_CHECK_PROGS([PNMTOPNG],[pnmtopng],[no])
+ AC_CHECK_PROGS([BMPTOPNM],[bmptopnm],[no])
+ AC_CHECK_PROGS([PAMCUT],[pamcut],[no])
+ if test "x$PBMTEXT" != "xno"; then
+ AC_DEFINE_UNQUOTED([PBMTEXT],["$PBMTEXT"],[Name of pbmtext program.])
+ fi
+ if test "x$PNMTOPNG" != "xno"; then
+ AC_DEFINE_UNQUOTED([PNMTOPNG],["$PNMTOPNG"],[Name of pnmtopng program.])
+ fi
+ if test "x$BMPTOPNM" != "xno"; then
+ AC_DEFINE_UNQUOTED([BMPTOPNM],["$BMPTOPNM"],[Name of bmptopnm program.])
+ fi
+ if test "x$PAMCUT" != "xno"; then
+ AC_DEFINE_UNQUOTED([PAMCUT],["$PAMCUT"],[Name of pamcut program.])
+ fi
dnl Check for icoutils (optional).
AC_CHECK_PROGS([WRESTOOL],[wrestool],[no])
if test "x$WRESTOOL" != "xno"; then
- AC_DEFINE_UNQUOTED([WRESTOOL],["$WRESTOOL"],[Name of wrestool program.])
+ AC_DEFINE_UNQUOTED([WRESTOOL],["$WRESTOOL"],[Name of wrestool program.])
fi
+],
+[])
dnl Check for QEMU for running binaries on this $host_cpu, fall
dnl back to basic 'qemu'. Allow the user to override it.