262 lines
13 KiB
Diff
262 lines
13 KiB
Diff
diff -Naur bibus-1.5.0/Makefile bibus-1.5.0.new/Makefile
|
|
--- bibus-1.5.0/Makefile 2009-10-08 16:53:13.000000000 -0400
|
|
+++ bibus-1.5.0.new/Makefile 2009-11-05 23:33:57.000000000 -0500
|
|
@@ -1,24 +1,25 @@
|
|
# you presumably will only have to change the three first lines below
|
|
-DESTDIR = /usr/local
|
|
+DESTDIR = ${D}usr
|
|
python = /usr/bin/python
|
|
oopath = /usr/lib/openoffice/program
|
|
-ooure = /usr/lib/openoffice.org/basis-link/ure-link/lib
|
|
+ooure = /usr/lib/openoffice/basis-link/ure-link/lib
|
|
oobasis = /usr/lib/openoffice/basis-link/program
|
|
#
|
|
prefix = $(DESTDIR)
|
|
exec_prefix = $(prefix)
|
|
bindir = $(exec_prefix)/bin
|
|
datadir = $(prefix)/share
|
|
-sysconfdir = /etc
|
|
+pythondir = $(prefix)/lib/gentoo-python/site-packages
|
|
+sysconfdir = ${D}etc
|
|
mandir = $(prefix)/share/man
|
|
man1dir = $(mandir)/man1
|
|
|
|
define install-files
|
|
- install -d $(datadir)/bibus
|
|
- install -m644 *.py MySQL_Bibus.ini $(datadir)/bibus/
|
|
+ install -d $(pythondir)/bibus
|
|
+ install -m644 *.py MySQL_Bibus.ini $(pythondir)/bibus/
|
|
#
|
|
for dir in Export Format Import StyleEditor FirstStart bibOOo db_models Pixmaps Data LyX Utilities; do \
|
|
- find $$dir ! -wholename '*CVS*' -a -type f -exec install -m644 '{}' -D $(datadir)/bibus/'{}' ';' ; \
|
|
+ find $$dir ! -wholename '*CVS*' -a -type f -exec install -m644 '{}' -D $(pythondir)/bibus/'{}' ';' ; \
|
|
done
|
|
install -m644 Setup/UnoConnectionListener.odg -D $(datadir)/bibus/Setup/UnoConnectionListener.odg
|
|
# locale files. We look for all the directory in locale/
|
|
@@ -35,41 +36,38 @@
|
|
# freedesktop icon and shortcut
|
|
install -m644 Pixmaps/bibus.png -D $(datadir)/icons/hicolor/48x48/apps/bibus.png
|
|
install -m644 Setup/bibus.desktop -D $(datadir)/applications/bibus.desktop
|
|
- # The following lines are presumably not needed since icons/desktop are in standard locations
|
|
- #echo 'Exec=$(bindir)/bibus' >> $(datadir)/applications/bibus.desktop
|
|
- #echo 'Icon=$(datadir)/icons/hicolor/48x48/apps/bibus.png' >> $(datadir)/applications/bibus.desktop
|
|
|
|
# bibus command
|
|
install -d $(bindir)
|
|
- ln -sf $(datadir)/bibus/bibusStart.py $(bindir)/bibus
|
|
- chmod 755 $(datadir)/bibus/bibusStart.py
|
|
+ ln -sf $(pythondir)/bibus/bibusStart.py $(bindir)/bibus
|
|
+ chmod 755 $(pythondir)/bibus/bibusStart.py
|
|
|
|
# basic doc files
|
|
- install -m755 -d $(datadir)/doc/bibus
|
|
- install -m644 Docs/*.txt Docs/CHANGELOG Docs/copying $(datadir)/doc/bibus
|
|
+ install -m755 -d $(datadir)/doc/${PF}
|
|
+ install -m644 Docs/*.txt Docs/CHANGELOG Docs/copying $(datadir)/doc/${PF}
|
|
|
|
# generating bibus.cfg file
|
|
- echo '[PATH]' > $(datadir)/bibus/bibus.cfg
|
|
- echo 'python = $(python)' >> $(datadir)/bibus/bibus.cfg
|
|
- echo 'oopath = $(oopath)' >> $(datadir)/bibus/bibus.cfg
|
|
- echo 'ooure = $(ooure)' >> $(datadir)/bibus/bibus.cfg
|
|
- echo 'oobasis = $(oobasis)' >> $(datadir)/bibus/bibus.cfg
|
|
- echo 'docdir = $(datadir)/doc/bibus/html' >> $(datadir)/bibus/bibus.cfg
|
|
- echo 'licence = $(datadir)/doc/bibus/copying' >> $(datadir)/bibus/bibus.cfg
|
|
- echo 'localedir = $(datadir)/locale' >> $(datadir)/bibus/bibus.cfg
|
|
- echo 'systemconf = $(sysconfdir)/bibus.config' >> $(datadir)/bibus/bibus.cfg
|
|
+ echo '[PATH]' > $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'python = $(python)' >> $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'oopath = $(oopath)' >> $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'ooure = $(ooure)' >> $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'oobasis = $(oobasis)' >> $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'docdir = /usr/share/doc/${PF}/html' >> $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'licence = /usr/share/doc/${PF}/copying' >> $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'localedir = /usr/share/locale' >> $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'systemconf = /etc/bibus.config' >> $(pythondir)/bibus/bibus.cfg
|
|
endef
|
|
|
|
define install-doc-en
|
|
# copying docs in from Docs/html/en/ for bibus-doc-en
|
|
cd Docs;\
|
|
- find html/en/* -type f -exec install -m644 '{}' -D $(datadir)/doc/bibus/'{}' ';'
|
|
+ find html/en/* -type f -exec install -m644 '{}' -D $(datadir)/doc/${PF}/'{}' ';'
|
|
endef
|
|
|
|
define compile
|
|
- # compile recursively all the python files located in $(datadir)/bibus
|
|
- $(python) -c "import compileall ; compileall.compile_dir('$(datadir)/bibus')"
|
|
- $(python) -O -c "import compileall ; compileall.compile_dir('$(datadir)/bibus')"
|
|
+ # compile recursively all the python files located in $(pythondir)/bibus
|
|
+ $(python) -c "import compileall ; compileall.compile_dir('$(pythondir)/bibus')"
|
|
+ $(python) -O -c "import compileall ; compileall.compile_dir('$(pythondir)/bibus')"
|
|
endef
|
|
|
|
install-files:
|
|
@@ -85,13 +83,15 @@
|
|
|
|
# write uninstaller in $(datadir)/bibus/Setup/uninstall.sh
|
|
echo "#!/bin/sh" > $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "rm -rf $(datadir)/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "rm $(bindir)/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "find $(datadir)/locale -name bibus.mo -exec rm -f {} \;" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "rm $(sysconfdir)/bibus.config" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "rm $(man1dir)/bibus.1" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "rm -rf $(datadir)/doc/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "rm $(datadir)/applications/bibus.desktop" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "rm $(datadir)/icons/hicolor/48x48/apps/bibus.png" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm -rf /usr/share/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm /usr/share/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm -rf /usr/lib/gentoo-python/site-packages/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm /usr/lib/gentoo-python/site-packages/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "find /usr/share/locale -name bibus.mo -exec rm -f {} \;" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm /etc/bibus.config" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm /usr/share/man/man1/bibus.1" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm -rf /usr/share/doc/${PF}" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm /usr/share/applications/bibus.desktop" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm /usr/share/icons/hicolor/48x48/apps/bibus.png" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
chmod 744 $(datadir)/bibus/Setup/uninstall.sh
|
|
# end uninstaller
|
|
diff -Naur bibus-1.5.0/Setup/Makefile bibus-1.5.0.new/Setup/Makefile
|
|
--- bibus-1.5.0/Setup/Makefile 2009-10-08 16:53:13.000000000 -0400
|
|
+++ bibus-1.5.0.new/Setup/Makefile 2009-11-05 22:25:14.000000000 -0500
|
|
@@ -1,24 +1,25 @@
|
|
# you presumably will only have to change the three first lines below
|
|
-DESTDIR = /usr/local
|
|
+DESTDIR = ${D}/usr
|
|
python = /usr/bin/python
|
|
oopath = /usr/lib/openoffice/program
|
|
-ooure = /usr/lib/openoffice.org/basis-link/ure-link/lib
|
|
+ooure = /usr/lib/openoffice/basis-link/ure-link/lib
|
|
oobasis = /usr/lib/openoffice/basis-link/program
|
|
#
|
|
prefix = $(DESTDIR)
|
|
exec_prefix = $(prefix)
|
|
bindir = $(exec_prefix)/bin
|
|
datadir = $(prefix)/share
|
|
-sysconfdir = /etc
|
|
+pythondir = $(prefix)/lib/gentoo-python/site-packages
|
|
+sysconfdir = ${D}etc
|
|
mandir = $(prefix)/share/man
|
|
man1dir = $(mandir)/man1
|
|
|
|
define install-files
|
|
- install -d $(datadir)/bibus
|
|
- install -m644 *.py MySQL_Bibus.ini $(datadir)/bibus/
|
|
+ install -d $(pythondir)/bibus
|
|
+ install -m644 *.py MySQL_Bibus.ini $(pythondir)/bibus/
|
|
#
|
|
for dir in Export Format Import StyleEditor FirstStart bibOOo db_models Pixmaps Data LyX Utilities; do \
|
|
- find $$dir ! -wholename '*CVS*' -a -type f -exec install -m644 '{}' -D $(datadir)/bibus/'{}' ';' ; \
|
|
+ find $$dir ! -wholename '*CVS*' -a -type f -exec install -m644 '{}' -D $(pythondir)/bibus/'{}' ';' ; \
|
|
done
|
|
install -m644 Setup/UnoConnectionListener.odg -D $(datadir)/bibus/Setup/UnoConnectionListener.odg
|
|
# locale files. We look for all the directory in locale/
|
|
@@ -35,41 +36,38 @@
|
|
# freedesktop icon and shortcut
|
|
install -m644 Pixmaps/bibus.png -D $(datadir)/icons/hicolor/48x48/apps/bibus.png
|
|
install -m644 Setup/bibus.desktop -D $(datadir)/applications/bibus.desktop
|
|
- # The following lines are presumably not needed since icons/desktop are in standard locations
|
|
- #echo 'Exec=$(bindir)/bibus' >> $(datadir)/applications/bibus.desktop
|
|
- #echo 'Icon=$(datadir)/icons/hicolor/48x48/apps/bibus.png' >> $(datadir)/applications/bibus.desktop
|
|
-
|
|
+
|
|
# bibus command
|
|
install -d $(bindir)
|
|
- ln -sf $(datadir)/bibus/bibusStart.py $(bindir)/bibus
|
|
- chmod 755 $(datadir)/bibus/bibusStart.py
|
|
+ ln -sf $(pythondir)/bibus/bibusStart.py $(bindir)/bibus
|
|
+ chmod 755 $(pythondir)/bibus/bibusStart.py
|
|
|
|
# basic doc files
|
|
- install -m755 -d $(datadir)/doc/bibus
|
|
- install -m644 Docs/*.txt Docs/CHANGELOG Docs/copying $(datadir)/doc/bibus
|
|
+ install -m755 -d $(datadir)/doc/${PF}
|
|
+ install -m644 Docs/*.txt Docs/CHANGELOG Docs/copying $(datadir)/doc/${PF}
|
|
|
|
# generating bibus.cfg file
|
|
- echo '[PATH]' > $(datadir)/bibus/bibus.cfg
|
|
- echo 'python = $(python)' >> $(datadir)/bibus/bibus.cfg
|
|
- echo 'oopath = $(oopath)' >> $(datadir)/bibus/bibus.cfg
|
|
- echo 'ooure = $(ooure)' >> $(datadir)/bibus/bibus.cfg
|
|
- echo 'oobasis = $(oobasis)' >> $(datadir)/bibus/bibus.cfg
|
|
- echo 'docdir = $(datadir)/doc/bibus/html' >> $(datadir)/bibus/bibus.cfg
|
|
- echo 'licence = $(datadir)/doc/bibus/copying' >> $(datadir)/bibus/bibus.cfg
|
|
- echo 'localedir = $(datadir)/locale' >> $(datadir)/bibus/bibus.cfg
|
|
- echo 'systemconf = $(sysconfdir)/bibus.config' >> $(datadir)/bibus/bibus.cfg
|
|
+ echo '[PATH]' > $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'python = $(python)' >> $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'oopath = $(oopath)' >> $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'ooure = $(ooure)' >> $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'oobasis = $(oobasis)' >> $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'docdir = /usr/share/doc/${PF}/html' >> $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'licence = /usr/share/doc/${PF}/copying' >> $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'localedir = /usr/share/locale' >> $(pythondir)/bibus/bibus.cfg
|
|
+ echo 'systemconf = /etc/bibus.config' >> $(pythondir)/bibus/bibus.cfg
|
|
endef
|
|
|
|
define install-doc-en
|
|
# copying docs in from Docs/html/en/ for bibus-doc-en
|
|
cd Docs;\
|
|
- find html/en/* -type f -exec install -m644 '{}' -D $(datadir)/doc/bibus/'{}' ';'
|
|
+ find html/en/* -type f -exec install -m644 '{}' -D $(datadir)/doc/${PF}/'{}' ';'
|
|
endef
|
|
|
|
define compile
|
|
# compile recursively all the python files located in $(datadir)/bibus
|
|
- $(python) -c "import compileall ; compileall.compile_dir('$(datadir)/bibus')"
|
|
- $(python) -O -c "import compileall ; compileall.compile_dir('$(datadir)/bibus')"
|
|
+ $(python) -c "import compileall ; compileall.compile_dir('$(pythondir)/bibus')"
|
|
+ $(python) -O -c "import compileall ; compileall.compile_dir('$(pythondir)/bibus')"
|
|
endef
|
|
|
|
install-files:
|
|
@@ -85,13 +83,15 @@
|
|
|
|
# write uninstaller in $(datadir)/bibus/Setup/uninstall.sh
|
|
echo "#!/bin/sh" > $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "rm -rf $(datadir)/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "rm $(bindir)/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "find $(datadir)/locale -name bibus.mo -exec rm -f {} \;" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "rm $(sysconfdir)/bibus.config" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "rm $(man1dir)/bibus.1" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "rm -rf $(datadir)/doc/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "rm $(datadir)/applications/bibus.desktop" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
- echo "rm $(datadir)/icons/hicolor/48x48/apps/bibus.png" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm -rf /usr/share/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm /usr/share/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm -rf /usr/lib/gentoo-python/site-packages/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm /usr/lib/gentoo-python/site-packages/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "find /usr/share/locale -name bibus.mo -exec rm -f {} \;" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm /etc/bibus.config" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm /usr/share/man/man1/bibus.1" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm -rf /usr/share/doc/${PF}" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm /usr/share/applications/bibus.desktop" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
+ echo "rm /usr/share/icons/hicolor/48x48/apps/bibus.png" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
chmod 744 $(datadir)/bibus/Setup/uninstall.sh
|
|
# end uninstaller
|
|
diff -Naur bibus-1.5.0/Setup/bibus.cfg bibus-1.5.0.new/Setup/bibus.cfg
|
|
--- bibus-1.5.0/Setup/bibus.cfg 2009-10-08 16:53:13.000000000 -0400
|
|
+++ bibus-1.5.0.new/Setup/bibus.cfg 2009-11-05 22:14:50.000000000 -0500
|
|
@@ -1,7 +1,7 @@
|
|
[PATH]
|
|
python = /usr/bin/python
|
|
oopath = /usr/lib/openoffice/program
|
|
-docdir = /usr/local/share/doc/bibus/html
|
|
-licence = /usr/local/share/doc/bibus/copying
|
|
-localedir = /usr/local/share/locale
|
|
-systemconf = /usr/local/etc/bibus.config
|
|
+docdir = /usr/share/doc/bibus-1.4.3.2-r1/html
|
|
+licence = /usr/share/doc/bibus-1.4.3.2-r1/copying
|
|
+localedir = /usr/share/locale
|
|
+systemconf = /etc/bibus.config
|
|
diff -Naur bibus-1.5.0/Setup/bibus.sh bibus-1.5.0.new/Setup/bibus.sh
|
|
--- bibus-1.5.0/Setup/bibus.sh 2009-10-08 16:53:13.000000000 -0400
|
|
+++ bibus-1.5.0.new/Setup/bibus.sh 2009-11-05 22:14:50.000000000 -0500
|
|
@@ -1,4 +1,4 @@
|
|
#!/bin/sh
|
|
-export LD_LIBRARY_PATH=/usr/lib/openoffice/program
|
|
-export PYTHONPATH=/usr/lib/openoffice/program
|
|
-exec /usr/bin/python /usr/local/share/bibus/bibus.py
|
|
+export LD_LIBRARY_PATH=/usr/lib/openoffice/program:/usr/lib/openoffice/basis-link/program:/usr/lib/openoffice/basis-link/ure-link/lib
|
|
+export PYTHONPATH=/usr/lib/openoffice/program:/usr/lib/openoffice/basis-link/program:/usr/lib/openoffice/basis-link/ure-link/lib
|
|
+exec /usr/bin/python /usr/lib/gentoo-python/site-packages/bibus/bibus.py
|