You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/vlc/files/vlc-2.2.0-xcb_vdpau.patch

16 lines
652 B

--- modules/hw/vdpau/Makefile.am.orig 2015-04-16 22:29:26.299342749 -0700
+++ modules/hw/vdpau/Makefile.am 2015-04-16 22:31:40.886340950 -0700
@@ -45,6 +45,7 @@
libvdpau_chroma_plugin_la_LIBADD = libvlc_vdpau.la
vdpau_LTLIBRARIES += libvdpau_chroma_plugin.la
+if HAVE_XCB
libvdpau_display_plugin_la_SOURCES = display.c
libvdpau_display_plugin_la_CPPFLAGS = $(AM_CPPFLAGS) -I$(srcdir)/../../video_output/xcb
libvdpau_display_plugin_la_CFLAGS = $(AM_CFLAGS) $(XCB_CFLAGS)
@@ -52,3 +53,4 @@
../../video_output/libvlc_xcb_events.la \
$(AM_LIBADD) $(X_LIBS) $(X_PRE_LIBS) -lX11 $(XCB_LIBS)
vdpau_LTLIBRARIES += libvdpau_display_plugin.la
+endif