You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/sxhkd/files/sxhkd-0.5.3-flags.patch

24 lines
531 B

--- sxhkd-0.5.3/Makefile
+++ sxhkd-0.5.3/Makefile
@@ -5,7 +5,6 @@
LIBS = -lm -lxcb -lxcb-keysyms
CFLAGS += -std=c99 -pedantic -Wall -Wextra -I$(PREFIX)/include
CFLAGS += -D_POSIX_C_SOURCE=200112L -DVERSION=\"$(VERSION)\"
-LDFLAGS += -L$(PREFIX)/lib
PREFIX ?= /usr/local
BINPREFIX = $(PREFIX)/bin
@@ -14,11 +13,9 @@
SRC = $(wildcard *.c)
OBJ = $(SRC:.c=.o)
-all: CFLAGS += -Os
-all: LDFLAGS += -s
all: $(NAME)
-debug: CFLAGS += -O0 -g -DDEBUG
+debug: CFLAGS += -DDEBUG
debug: $(NAME)
include Sourcedeps