You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/cbm/files/cbm-0.1-tinfo.patch

20 lines
463 B

--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,4 +3,4 @@
cbm_SOURCES = cbm.cpp \
ErrnoError.hpp \
statistics.cpp statistics.hpp
-cbm_LDADD = -lncurses widgets/libwidgets.la
+cbm_LDADD = $(ncurses_LIBS) widgets/libwidgets.la
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,8 @@
# Checks for libraries.
+PKG_CHECK_MODULES(ncurses,ncurses)
+
# Checks for header files.
# Checks for typedefs, structures, and compiler characteristics.