You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-forensics/sleuthkit/files/sleuthkit-4.10.1-exclude-us...

29 lines
858 B

From: Gokturk Yuksek <gokturk@gentoo.org>
Do not allow the build system to use libs from /usr/local.
Bug: https://bugs.gentoo.org/774039
--- a/configure.ac
+++ b/configure.ac
@@ -92,19 +92,6 @@
dnl Enable multithreading by default in the presence of pthread
AS_IF([test "x$ax_pthread_ok" = "xyes" && test "x$enable_multithreading" != "xno"], [ax_multithread=yes], [ax_multithread=no])
-case "$host" in
-*-*-mingw*)
- dnl Adding the native /usr/local is wrong for cross-compiling
- ;;
-*)
- dnl Not all compilers include /usr/local in the include and link path
- if test -d /usr/local/include; then
- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
- LDFLAGS="$LDFLAGS -L/usr/local/lib"
- fi
- ;;
-esac
-
dnl Add enable/disable option
AC_ARG_ENABLE([java],
[AS_HELP_STRING([--disable-java], [Do not build the java bindings or jar file])])