You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/capstone/files/capstone-4.0-FLAGS.patch

21 lines
418 B

Drop -O3 and allow user to specify their optimizations.
--- a/cstool/Makefile
+++ b/cstool/Makefile
@@ -1,13 +1,14 @@
# Makefile for Cstool of Capstone Disassembly Engine
include ../functions.mk
+include ../config.mk
.PHONY: clean all
LIBNAME = capstone
CFLAGS += -I../include -I.
-LDFLAGS += -O3 -Wall -L.. -l$(LIBNAME)
+LDFLAGS += -Wall -L.. -l$(LIBNAME)
TARGET = cstool
SOURCES := $(wildcard *.c)