You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-admin/collectd/files/collectd-5.5.1-libocci.patch

34 lines
939 B

[PATCH 1/3] Link Oracle plug-in against libocci
Author: Aurelien Minet
X-Gentoo-Bug: 347607
X-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=347607
---
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index fc1e11c..b977a0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3248,14 +3248,14 @@ AC_ARG_WITH(oracle, [AS_HELP_STRING([--with-oracle@<:@=ORACLE_HOME@:>@], [Path t
])
if test "x$ORACLE_HOME" != "x"
then
- with_oracle_cppflags="-I$ORACLE_HOME/rdbms/public"
+ with_oracle_cppflags="-I$ORACLE_HOME/rdbms/public -locci"
if test -e "$ORACLE_HOME/lib/ldflags"
then
with_oracle_libs=`cat "$ORACLE_HOME/lib/ldflags"`
fi
#with_oracle_libs="-L$ORACLE_HOME/lib $with_oracle_libs -lclntsh"
- with_oracle_libs="-L$ORACLE_HOME/lib -lclntsh"
+ with_oracle_libs="-L$ORACLE_HOME/lib -lclntsh -locci"
fi
if test "x$with_oracle" = "xyes"
then
--
2.7.1