You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-chemistry/mosflm/files/7.0.6-parallel.patch

29 lines
654 B

--- cbf/Makefile 2009-08-31 09:35:06.000000000 +0200
+++ cbf/Makefile.new 2009-08-31 10:44:46.000000000 +0200
@@ -362,6 +362,8 @@
$(EXAMPLES)/img.h \
$(INCLUDE)/md5.h
+OBJ = $(subst .c,.o,$(SOURCE))
+
#
# Compile the library and examples
#
@@ -379,11 +381,14 @@
$(LIB):
mkdir $(LIB)
+
+.c.o: $(SOURCE) $(HEADERS)
+ $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $<
+
#
# CBF library
#
-$(LIB)/libcbf.a: $(SOURCE) $(HEADERS) $(COMMONDEP)
- $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $(SOURCE)
+$(LIB)/libcbf.a: $(OBJ) $(COMMONDEP)
$(AR) cr $@ *.o
rm *.o
if [ -f $(RANLIB) ]; then $(RANLIB) $@ ; fi