You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/libpri/files/libpri-1.6.0-respect-user-f...

54 lines
1.6 KiB

diff -uNr libpri-1.6.0.ORIG/Makefile libpri-1.6.0/Makefile
--- libpri-1.6.0.ORIG/Makefile 2017-09-19 10:37:05.176546588 +0100
+++ libpri-1.6.0/Makefile 2017-09-19 10:37:41.029544605 +0100
@@ -24,10 +24,6 @@
# Uncomment if you want libpri not send PROGRESS_INDICATOR w/ALERTING
#ALERTING=-DALERTING_NO_PROGRESS
-CC=gcc
-GREP=grep
-AWK=awk
-
OSARCH=$(shell uname -s)
PROC?=$(shell uname -m)
@@ -68,7 +64,7 @@
$(STATIC_OBJS)
CFLAGS ?= -g
CFLAGS += $(CPPFLAGS)
-CFLAGS += -Wall -Werror -Wstrict-prototypes -Wmissing-prototypes
+CFLAGS += -Wall -Wstrict-prototypes -Wmissing-prototypes
CFLAGS += -fPIC $(ALERTING) $(LIBPRI_OPT) $(COVERAGE_CFLAGS)
INSTALL_PREFIX=$(DESTDIR)
INSTALL_BASE=/usr
@@ -108,17 +104,12 @@
#The problem with sparc is the best stuff is in newer versions of gcc (post 3.0) only.
#This works for even old (2.96) versions of gcc and provides a small boost either way.
#A ultrasparc cpu is really v9 but the stock debian stable 3.0 gcc doesnt support it.
-ifeq ($(PROC),sparc64)
-PROC=ultrasparc
-LIBPRI_OPT = -mtune=$(PROC) -O3 -pipe -fomit-frame-pointer -mcpu=v8
-else
- ifneq ($(CODE_COVERAGE),)
+ifneq ($(CODE_COVERAGE),)
LIBPRI_OPT=
COVERAGE_CFLAGS=-ftest-coverage -fprofile-arcs
COVERAGE_LDFLAGS=-ftest-coverage -fprofile-arcs
- else
- LIBPRI_OPT=-O2
- endif
+else
+ LIBPRI_OPT=
endif
ifeq ($(CPUARCH),i686)
@@ -197,7 +188,7 @@
ranlib $(STATIC_LIBRARY)
$(DYNAMIC_LIBRARY): $(DYNAMIC_OBJS)
- $(CC) $(SOFLAGS) -o $@ $(DYNAMIC_OBJS)
+ $(CC) $(SOFLAGS) $(LDFLAGS) -o $@ $(DYNAMIC_OBJS)
$(LDCONFIG) $(LDCONFIG_FLAGS) .
ln -sf $(DYNAMIC_LIBRARY) libpri.so