You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-news/newsboat/files/newsboat-2.23-flags.patch

17 lines
523 B

diff --git a/Makefile b/Makefile
index ee890bc3..c5fed3b6 100644
--- a/Makefile
+++ b/Makefile
@@ -49,9 +49,9 @@ CXX_FOR_BUILD?=$(CXX)
# compiler and linker flags
DEFINES=-DLOCALEDIR='"$(localedir)"'
-WARNFLAGS=-Werror -Wall -Wextra -Wunreachable-code
+WARNFLAGS=-Wall -Wextra -Wunreachable-code
INCLUDES=-Iinclude -Istfl -Ifilter -I. -Irss -I$(relative_cargo_target_dir)/cxxbridge/libnewsboat-ffi/src/
-BARE_CXXFLAGS=-std=c++11 -O2 -ggdb $(INCLUDES)
+BARE_CXXFLAGS=-std=c++11 $(INCLUDES)
LDFLAGS+=-L.
# Constants