You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libxml2/files/libxml2-2.9.0-disable_stati...

22 lines
837 B

diff --git a/python/Makefile.am b/python/Makefile.am
index 4a8b5d5..b976893 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -19,13 +19,14 @@ if WITH_PYTHON
AM_CPPFLAGS = \
-I$(top_builddir)/include \
-I$(top_srcdir)/include \
- -I$(PYTHON_INCLUDES)
+ -I$(PYTHON_INCLUDES) \
+ -shared
python_LTLIBRARIES = libxml2mod.la
libxml2mod_la_SOURCES = libxml.c libxml_wrap.h libxml2-py.h libxml2-py.c types.c
libxml2mod_la_LIBADD = $(top_builddir)/libxml2.la $(CYGWIN_EXTRA_PYTHON_LIBADD) $(WIN32_EXTRA_PYTHON_LIBADD) $(PYTHON_LIBS) -lpython$(PYTHON_VERSION)
-libxml2mod_la_LDFLAGS = $(CYGWIN_EXTRA_LDFLAGS) $(WIN32_EXTRA_LDFLAGS) -module -avoid-version
+libxml2mod_la_LDFLAGS = $(CYGWIN_EXTRA_LDFLAGS) $(WIN32_EXTRA_LDFLAGS) -module -avoid-version -shared
BUILT_SOURCES = libxml2-export.c libxml2-py.h libxml2-py.c