You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-auth/authenticator/files/disable-failing-tests.patch

25 lines
784 B

diff --git a/data/meson.build b/data/meson.build
index d21a6d1..b2a849b 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -50,10 +50,12 @@ endif
appstreamcli = find_program(['appstreamcli', 'appstream-util'], required:false)
-if appstreamcli.found()
- test (
- 'Validate appdata file',
- appstreamcli,
- args: ['validate', join_paths(meson.current_build_dir (), meson.project_name() + '.appdata.xml')]
- )
-endif
+# This test fails because screenshot images do not comply with restrictions.
+# See https://github.com/bilelmoussaoui/Authenticator/issues/67
+#if appstreamcli.found()
+# test (
+# 'Validate appdata file',
+# appstreamcli,
+# args: ['validate', join_paths(meson.current_build_dir (), meson.project_name() + '.appdata.xml')]
+# )
+#endif