You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-text/hd2u/files/hd2u-1.0.3-build.patch

26 lines
666 B

diff --git a/Makefile.in b/Makefile.in
index 2a67b3c..651323d 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -42,7 +42,7 @@ LIBS= @LIBS@
all: $(TARGET)
$(TARGET): $(TARGET).c config.h
- $(CC) $(CFLAGS) -o $@ $(@:%=%.c) $(LIBS)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(@:%=%.c) $(LIBS)
all-optimized: $(TARGET)-optimized
@@ -98,9 +98,10 @@ cleanall: clean
mrproper: cleanall
distclean: cleanall
+BUILD_ROOT=$(DESTDIR)
install:
$(INSTALL) -d -m 755 $(BUILD_ROOT)$(BIN_DIR)
- $(INSTALL) -m 755 -s $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
+ $(INSTALL) -m 755 $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
tarball:
$(INSTALL) -d -m 755 ./$(PACKAGE_NAME)-$(PACKAGE_VERSION)