You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/apr/files/apr-1.6.3-skip-known-failin...

19 lines
512 B

Skip testlfs test which only runs on non 64-bit systems and fails
on Gentoo due to a sandbox issue. Bug #603244
--- a/test/Makefile.in
+++ b/test/Makefile.in
@@ -172,7 +172,11 @@ check: $(TESTALL_COMPONENTS) $(STDTEST_PORTABLE) $(STDTEST_NONPORTABLE)
fi; \
done; \
else \
- ./$$prog -v; \
+ if test "$$prog" = 'testall@EXEEXT@'; then \
+ ./$$prog -v -x testlfs; \
+ else \
+ ./$$prog -v; \
+ fi; \
status=$$?; \
if test $$status != 0; then \
teststatus=$$status; \