You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/foma/files/foma-0.9.18-clean-makefile....

36 lines
1.3 KiB

diff -Naur a/Makefile b/Makefile
--- a/Makefile 2015-06-13 06:24:02.000000000 +0300
+++ b/Makefile 2019-09-08 09:24:22.127655912 +0300
@@ -1,21 +1,16 @@
-prefix = /usr/local
+prefix = /usr
exec_prefix = $(prefix)
libdir = $(exec_prefix)/lib
bindir = $(exec_prefix)/bin
includedir = $(prefix)/include
VERSION = 0.9.18
-CC = gcc
-RANLIB = ranlib
YACC = bison -v
LEX = flex -8
LEXCLEX = flex -8 --prefix=lexc
LEXIFACE = flex -8 --prefix=interface
LEXCMATRIX = flex -8 --prefix=cmatrix
RM = /bin/rm -f
-LDFLAGS = -lreadline -lz -ltermcap
-FLOOKUPLDFLAGS = libfoma.a -lz
-CFLAGS = -O3 -Wall -D_GNU_SOURCE -std=c99 -fvisibility=hidden -fPIC
FOMAOBJS = foma.o stack.o iface.o lex.interface.o
LIBOBJS = int_stack.o define.o determinize.o apply.o rewrite.o lexcread.o topsort.o flags.o minimize.o reverse.o extract.o sigma.o io.o structures.o constructions.o coaccessible.o utf8.o spelling.o dynarray.o mem.o stringhash.o trie.o lex.lexc.o lex.yy.o lex.cmatrix.o regex.o
@@ -82,7 +77,7 @@
if test -f $(libdir)/$(SHAREDLIB); then rm $(libdir)/$(SHAREDLIB); fi
if test -f $(libdir)/$(SHAREDLIBM); then rm $(libdir)/$(SHAREDLIBM); fi
cd $(libdir); ln -s $(SHAREDLIBV) $(SHAREDLIB); cd $(libdir); \
- ln -s $(SHAREDLIBV) $(SHAREDLIBM); (ldconfig || true) \
+ ln -s $(SHAREDLIBV) $(SHAREDLIBM); \
>/dev/null 2>&1; \
$(OBJS): foma.h