You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-vpn/vpncwatch/files/vpncwatch-1.8-Makefile.patch

24 lines
586 B

Makefile | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index 901e0ae..599499a 100644
--- a/Makefile
+++ b/Makefile
@@ -10,13 +10,13 @@ OBJS = vpncwatch.o proc.o net.o
DISTFILES = AUTHORS COPYING README Makefile $(SRCS) $(HDRS) vpnc-watch.py
CC ?= gcc
-CFLAGS = -D_GNU_SOURCE -O2 -Wall -Werror
+CFLAGS += -D_GNU_SOURCE -Wall
# Update version in vpncwatch.h as well
TAG = vpncwatch-1.8
vpncwatch: $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(OBJS)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS)
.c.o:
$(CC) $(CFLAGS) -c -o $@ $<