You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-mathematics/arb/files/arb-2.11.1-pie-ftbs.patch

18 lines
585 B

Description: Use -r instead of -Wl,-r to fix FTBFS with PIE enabled
Author: Logan Rosen
Forwarded: yes
diff --git a/Makefile.subdirs b/Makefile.subdirs
index 3dc757d..f0ec923 100644
--- a/Makefile.subdirs
+++ b/Makefile.subdirs
@@ -52,7 +52,7 @@ $(BUILD_DIR)/$(MOD_DIR)_%.o: %.c
$(QUIET_CC) $(CC) $(CFLAGS) $(INCS) -c $< -o $@ -MMD -MP -MF "$(BUILD_DIR)/$(MOD_DIR)_$*.d" -MT "$(BUILD_DIR)/$(MOD_DIR)_$*.d" -MT "$@"
$(MOD_LOBJ): $(LOBJS)
- $(QUIET_CC) $(CC) $(ABI_FLAG) -Wl,-r $^ -o $@ -nostdlib
+ $(QUIET_CC) $(CC) $(ABI_FLAG) -r $^ -o $@ -nostdlib
-include $(LOBJS:.lo=.d)