You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-devel/autoconf/files/autoconf-2.13-gentoo.patch

37 lines
799 B

--- a/configure
+++ b/configure
@@ -654,12 +654,10 @@
echo "$ac_t""no" 1>&6
fi
-if test "$PERL" != no; then
- SCRIPTS=autoscan
-else
- echo "configure: warning: autoscan will not be built since perl is not found" 1>&2
+if test "$PERL" = no; then
+ PERL=/usr/bin/perl
fi
-
+SCRIPTS=autoscan
ac_aux_dir=
for ac_dir in $srcdir $srcdir/.. $srcdir/../..; do
if test -f $ac_dir/install-sh; then
--- a/configure.in
+++ b/configure.in
@@ -14,12 +14,10 @@
AC_PATH_PROG(PERL, perl, no)
AC_SUBST(PERL)dnl
AC_SUBST(SCRIPTS)dnl
-if test "$PERL" != no; then
- SCRIPTS=autoscan
-else
- AC_MSG_WARN(autoscan will not be built since perl is not found)
+if test "$PERL" = no; then
+ PERL=/usr/bin/perl
fi
-
+SCRIPTS=autoscan
AC_PROG_INSTALL
# Work with the GNU or Cygnus source tree layout.