You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ada/gnatcoll/files/gnatcoll-2017-gentoo.patch

145 lines
5.6 KiB

--- a/Makefile 2017-01-20 19:39:07.131398270 +0100
+++ b/Makefile 2017-01-20 19:42:30.088728844 +0100
@@ -43,18 +43,18 @@
# Build either type of library. The argument (%) is the type of library to build
-GPRBLD_OPTS=-p -m -j${PROCESSORS} -XLIBRARY_TYPE=$(@F) -XGnatcoll_Build=${Gnatcoll_Build} -XXMLADA_BUILD=$(@F)
+GPRBLD_OPTS=-p -m -j${PROCESSORS} -XGPR_BUILD=$(@F) -XLIBRARY_TYPE=$(@F) -XGnatcoll_Build=${Gnatcoll_Build} -XXMLADA_BUILD=$(@F)
build_library_type/%: generate_sources
@${RM} src/gnatcoll-atomic.adb
@echo "====== Building $(@F) libraries ======"
- ${GPRBUILD} ${GPRBLD_OPTS} -Pgnatcoll_full
+ ${GPRBUILD} ${GPRBLD_OPTS} -Pgnatcoll_full -v -cargs ${ADAFLAGS}
@# Need to build libgnatcoll_gtk separately, because its project files
@# requires gtkada.gpr, which might not exist on the machine.
ifeq (${WITH_GTK},yes)
- ${GPRBUILD} ${GPRBLD_OPTS} -Psrc/gnatcoll_gtk
+ ${GPRBUILD} ${GPRBLD_OPTS} -Psrc/gnatcoll_gtk -v -cargs ${ADAFLAGS}
endif
build_tools/%: build_library_type/%
@@ -63,13 +63,14 @@
@# They are not build as part of the above because only the Main from
@# gnatcoll_full.gpr are build. We could use aggregate projects to
@# speed things up.
- ${GPRBUILD} ${GPRBLD_OPTS} -q -Psrc/gnatcoll_tools
+ ${GPRBUILD} ${GPRBLD_OPTS} -q -Psrc/gnatcoll_tools -v -cargs ${ADAFLAGS}
#######################################################################
# install
GPRINST_OPTS=-p -f --prefix=${prefix} --install-name=gnatcoll \
--exec-subdir=${bindir} --project-subdir=lib/gnat -XXMLADA_BUILD=$(@F) \
+ -XGPR_BUILD=$(@F) \
--build-var=LIBRARY_TYPE --build-name=$(@F) -XLIBRARY_TYPE=$(@F)
install-clean:
--- a/gnatcoll_shared.gpr.in 2017-01-20 19:50:03.222808656 +0100
+++ b/gnatcoll_shared.gpr.in 2017-01-20 19:50:28.200399274 +0100
@@ -13,7 +13,7 @@
type Yes_No is ("yes", "no");
Gtk : Yes_No := External ("GTK", "@WITH_GTK@");
- Python : Yes_No := External ("PYTHON", "@WITH_PYTHON@");
+ Python : Yes_No := "@WITH_PYTHON@";
Syslog : Yes_No := External ("SYSLOG", "@WITH_SYSLOG@");
Postgres : Yes_No := External ("POSTGRES", "@WITH_POSTGRES@");
type Sqlite_Inclusion is ("yes", "no", "embedded");
--- a/aclocal.m4 2017-04-06 08:25:14.796699365 +0200
+++ b/aclocal.m4 2017-04-06 08:25:36.622318016 +0200
@@ -45,7 +45,7 @@
cat > conftest.ada <<EOF
[$3]
EOF
- if AC_TRY_COMMAND([gnatchop -q conftest.ada && $1 $2 >/dev/null 2>conftest.out])
+ if AC_TRY_COMMAND([${GNATCHOP} -q conftest.ada && $1 $2 >/dev/null 2>conftest.out])
then
: Success
$4
@@ -68,7 +68,7 @@
AC_DEFUN(AM_HAS_INTRINSIC_SYNC_COUNTERS,
[
AC_MSG_CHECKING([whether platform supports atomic inc/dec])
- AM_TRY_ADA([gnatmake], [check.adb],
+ AM_TRY_ADA([${GNATMAKE}], [check.adb],
[
with Interfaces; use Interfaces;
procedure Check is
--- a/testsuite/json/__init__.py 2017-04-24 17:52:34.158513249 +0200
+++ b/testsuite/json/__init__.py 2017-04-24 17:52:52.636207017 +0200
@@ -21,7 +21,7 @@
@requires_not_aix # Storage_Error on that machine
@chdir("MB28-001")
def test_MB28_001(self):
- self.runexec(["python", "make_json.py"])
+ self.runexec(["python2.7", "make_json.py"])
self.gprbuild()
self.runexec("json_stack_test", "test.out")
--- a/testsuite/projects/__init__.py 2017-04-24 19:10:30.465246199 +0200
+++ b/testsuite/projects/__init__.py 2017-04-24 19:10:42.768035080 +0200
@@ -105,25 +105,6 @@
self.gprbuild("default.gpr")
self.runexec("main", "")
- @support.requires_not_windows
- @chdir("N918-040")
- def test_bareboard(self):
- self.create_fake_bb_compiler('install', 'arm-eabi', '6.1.0w', '3.4.6')
-
- # Make sure auto.cgpr is not deleted on exit
- try:
- os.unlink('auto.cgpr')
- except:
- pass
- self.gprbuild('main_prj', switches=['--autoconf=auto.cgpr'])
- m = re.search('for Target use "(.*?)"', open('auto.cgpr').read())
- target = m.group(1)
-
- def customFilter(actual):
- return actual.replace(target, "<native>")
-
- self.runexec(['sh', 'test.sh'], 'test.out', customFilter=customFilter)
-
@chdir("NB12-045")
def test_NB12_045(self):
# Test registering attribute in unknown package
--- a/src/tools/gnatcoll_db2ada.adb 2017-04-24 21:36:09.193973179 +0200
+++ b/src/tools/gnatcoll_db2ada.adb 2017-04-24 21:36:16.029858932 +0200
@@ -211,7 +211,7 @@
declare
Output : constant String := Get_Command_Output
- (Command => "python",
+ (Command => "python2.7",
Arguments => Args,
Input => "",
Status => Status'Access,
--- a/src/gnatcoll-projects.ads 2017-11-25 14:50:06.919939453 +0100
+++ b/src/gnatcoll-projects.ads 2017-11-25 14:50:38.932387204 +0100
@@ -1917,7 +1917,8 @@
Predefined_Source_Files : GNATCOLL.VFS.File_Array_Access;
-- The list of source files in Predefined_Source_Path
- Default_Gnatls : GNAT.Strings.String_Access := new String'("gnatls");
+ Default_Gnatls : GNAT.Strings.String_Access :=
+ new String'("@GNATLS@");
-- The default gnatls command to run.
Xrefs_Subdir : GNAT.Strings.String_Access;
--- a/src/tools/gnatinspect.adb 2017-11-25 14:52:47.282170250 +0100
+++ b/src/tools/gnatinspect.adb 2017-11-25 14:52:57.691990254 +0100
@@ -642,7 +642,7 @@
GNAT_Version : GNAT.Strings.String_Access;
begin
Env.Set_Path_From_Gnatls
- (Gnatls => "gnatls",
+ (Gnatls => "@GNATLS@",
GNAT_Version => GNAT_Version,
Errors => Local_On_Error'Unrestricted_Access);
Free (GNAT_Version);