You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/dhcp/files/dhcp-4.3.4-bind-disable.patch

39 lines
1.3 KiB

--- dhcp-4.3.4/bind/Makefile.in
+++ dhcp-4.3.4/bind/Makefile.in
@@ -40,6 +40,7 @@
@BIND_ATF_TRUE@all: bind1 atf bind2
bind1:
+disable:
# Extract the source from the tarball, if it hasn't been already.
@if test -d ${bindsrcdir} ; then \
echo ${bindsrcdir} already unpacked... ; \
@@ -68,6 +69,7 @@
fi
atf:
+disable:
# Build and copy the ATF support if not yet installed.
@if test -d ./atf ; then \
echo ATF support already installed ; \
@@ -82,6 +84,7 @@
@CROSS_COMPILING_TRUE@bind2: bind2-hostgen
bind2-noguest:
+disable:
# Build and install the export libraries
# No need to do anything if we already have something installed.
@if test -d ${binddir}/lib ; then \
@@ -98,6 +101,7 @@
fi
bind2-hostgen:
+disable:
# Build and install the export libraries
# No need to do anything if we already have something installed.
@if test -d ${binddir}/lib ; then \
--- dhcp-4.3.4/bind/test
+++ dhcp-4.3.4/bind/test
@@ -0,0 +1 @@
+--disable-kqueue --disable-epoll --disable-devpoll --without-openssl --without-libxml2 --enable-exportlib --with-gssapi=no --enable-threads=no @BINDCONFIG@ --with-export-includedir=${binddir}/include --with-export-libdir=${binddir}/lib