You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-irc/xaric/files/xaric-0.13.6-tinfo.patch

17 lines
740 B

--- a/configure.ac
+++ b/configure.ac
@@ -279,9 +279,10 @@
olibs="$LIBS"
AC_CHECK_LIB(termcap, tgetent, LIBS="-ltermcap $olibs",
AC_CHECK_LIB(termlib, tgetent, LIBS="-ltermlib $olibs",
- AC_CHECK_LIB(curses, tgetent, LIBS="-lcurses $olibs",
- AC_CHECK_LIB(xtermcap, tgetent, LIBS="-lxtermcap $olibs",
- AC_MSG_ERROR([i can not find tgetent. you need to help me])))))
+ AC_CHECK_LIB(tinfo, tgetent, LIBS="-ltinfo $olibs",
+ AC_CHECK_LIB(curses, tgetent, LIBS="-lcurses $olibs",
+ AC_CHECK_LIB(xtermcap, tgetent, LIBS="-lxtermcap $olibs",
+ AC_MSG_ERROR([i can not find tgetent. you need to help me]))))))
fi
dnl ----------------------------------------------------------