You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/hiredis/files/hiredis-1.0.1-system-libs.p...

16 lines
519 B

diff -Nur hiredis-1.0.1.orig/setup.py hiredis-1.0.1/setup.py
--- hiredis-1.0.1.orig/setup.py 2019-11-13 11:38:29.000000000 +0100
+++ hiredis-1.0.1/setup.py 2020-03-19 08:18:53.414214592 +0100
@@ -11,9 +11,8 @@
return module.__version__
ext = Extension("hiredis.hiredis",
- sources=sorted(glob.glob("src/*.c") +
- ["vendor/hiredis/%s.c" % src for src in ("read", "sds")]),
- include_dirs=["vendor"])
+ sources=sorted(glob.glob("src/*.c")),
+ libraries=["hiredis"])
setup(
name="hiredis",