You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/liboggz/files/liboggz-1.1.1-destdir.patch

15 lines
550 B

--- a/src/tools/Makefile.am
+++ b/src/tools/Makefile.am
@@ -75,10 +75,7 @@
# see http://lists.xiph.org/pipermail/ogg-dev/2008-July/001083.html
install-exec-local:
for p in dump diff info merge rip ; do \
- if test -e $(exec_prefix)/bin/oggz$$p ; then \
- $(RM) $(exec_prefix)/bin/oggz$$p ; \
- $(LN_S) $(exec_prefix)/bin/oggz-$$p $(exec_prefix)/bin/oggz$$p ; \
- fi ; \
+ $(LN_S) $(exec_prefix)/bin/oggz-$$p $(DESTDIR)$(exec_prefix)/bin/oggz$$p ; \
done
# On 'make uninstall', remove the deprecated tool -- but only if it is a