You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-terms/kitty/files/kitty-0.16.0-remove-terminf...

15 lines
614 B

--- a/setup.py
+++ b/setup.py
@@ -837,11 +837,6 @@
safe_makedirs(launcher_dir)
build_launcher(args, launcher_dir, bundle_type)
os.makedirs(os.path.join(libdir, 'logo'))
- build_terminfo = runpy.run_path('build-terminfo', run_name='import_build')
- for x in (libdir, os.path.join(ddir, 'share')):
- odir = os.path.join(x, 'terminfo')
- safe_makedirs(odir)
- build_terminfo['compile_terminfo'](odir)
shutil.copy2('__main__.py', libdir)
shutil.copy2('logo/kitty.rgba', os.path.join(libdir, 'logo'))
shutil.copy2('logo/kitty.png', os.path.join(libdir, 'logo'))