You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-devel/automake/files/automake-1.4-CVE-2009-4029....

66 lines
2.1 KiB

http://bugs.gentoo.org/295357
(Makefile.in mangled a little for 1.4_p6)
From 449d20aa12e13fefd848604225fc83d0c39c61d0 Mon Sep 17 00:00:00 2001
From: Jim Meyering <meyering@redhat.com>
Date: Tue, 1 Dec 2009 22:48:15 +0100
Subject: [PATCH 1/1] do not put world-writable directories in distribution tarballs
* automake.in (handle_dist_worker): Do not make all directories
group- or world-writable. Instead, use 755.
Signed-off-by: Ralf Wildenhues <Ralf.Wildenhues@gmx.de>
---
Makefile.in | 4 ++--
automake.in | 4 ++--
4 files changed, 14 insertions(+), 4 deletions(-)
diff --git a/Makefile.in b/Makefile.in
index 93da407..59eb9f4 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -456,7 +456,7 @@ dist-all: distdir
distdir: $(DISTFILES)
-rm -rf $(distdir)
mkdir $(distdir)
- -chmod 777 $(distdir)
+ -chmod 755 $(distdir)
@for file in $(DISTFILES); do \
d=$(srcdir); \
if test -d $$d/$$file; then \
@@ -477,7 +477,7 @@ distdir: $(DISTFILES)
test -d $(distdir)/$$subdir \
|| mkdir $(distdir)/$$subdir \
|| exit 1; \
- chmod 777 $(distdir)/$$subdir; \
+ chmod 755 $(distdir)/$$subdir; \
(cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) top_distdir=../$(distdir) distdir=../$(distdir)/$$subdir distdir) \
|| exit 1; \
fi; \
diff --git a/automake.in b/automake.in
index 8eceea7..8f48236 100755
--- a/automake.in
+++ b/automake.in
@@ -2336,7 +2336,7 @@ sub handle_dist_worker
# Create dist directory.
$output_rules .= ("\t-rm -rf \$(distdir)\n"
. "\tmkdir \$(distdir)\n"
- . "\t-chmod 777 \$(distdir)\n");
+ . "\t-chmod 755 \$(distdir)\n");
}
# Only run automake in `dist' target if --include-deps and
@@ -2468,7 +2468,7 @@ sub handle_dist_worker
. "\t" . ' test -d $(distdir)/$$subdir ' . "\\\n"
. "\t" . ' || mkdir $(distdir)/$$subdir ' . "\\\n"
. "\t" . ' || exit 1; ' . "\\\n"
- . "\t" . ' chmod 777 $(distdir)/$$subdir; ' . "\\\n"
+ . "\t" . ' chmod 755 $(distdir)/$$subdir; ' . "\\\n"
. "\t" . ' (cd $$subdir'
. ' && $(MAKE) $(AM_MAKEFLAGS) top_distdir=../$('
. (($relative_dir eq '.') ? 'distdir' : 'top_distdir')
--
1.6.5.4