You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/wmname/files/wmname-0.1-buildsystem.patch

27 lines
504 B

--- wmname-0.1/config.mk
+++ wmname-0.1/config.mk
@@ -16,9 +16,9 @@
# flags
CPPFLAGS = -DVERSION=\"${VERSION}\"
-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
-LDFLAGS = -s ${LIBS}
+CFLAGS += -std=c99 -pedantic ${INCS} ${CPPFLAGS}
+LDFLAGS += ${LIBS}
# compiler and linker
-CC = cc
-LD = ${CC}
+CC ?= cc
+LD ?= ${CC}
--- wmname-0.1/Makefile
+++ wmname-0.1/Makefile
@@ -23,7 +23,6 @@
wmname: ${OBJ}
@echo LD $@
@${LD} -o $@ ${OBJ} ${LDFLAGS}
- @strip $@
clean:
@echo cleaning