You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-java/tijmp/files/tijmp-0.8-respect-javacflag...

12 lines
433 B

--- a/Makefile.am
+++ b/Makefile.am
@@ -18,7 +18,7 @@
java_files := $(foreach dir,$(dirs),$(find_files))
class_files := $(patsubst $(jdir)/%.java,%.class,$(java_files))
-JCFLAGS := -source 1.6 -encoding ISO-8859-1 -Xlint:unchecked -deprecation
+JCFLAGS := $(JAVACFLAGS) -encoding ISO-8859-1 -Xlint:unchecked -deprecation
# standard java compilation..
JAVACOMPILE := $(JAVAC) $(JCFLAGS) -sourcepath $(jdir) -d $(top_builddir)