You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/netpbm/files/netpbm-10.76.00-misc-deps.p...

69 lines
1.6 KiB

do not autoprobe deps when we disabled them
--- a/GNUmakefile
+++ b/GNUmakefile
@@ -74,7 +74,10 @@ include $(BUILDDIR)/config.mk
PROG_SUBDIRS = converter analyzer editor generator other
PRODUCT_SUBDIRS = lib $(PROG_SUBDIRS)
-SUPPORT_SUBDIRS = urt icon buildtools test
+SUPPORT_SUBDIRS = icon buildtools test
+ifeq ($(URTLIB),$(BUNDLED_URTLIB))
+SUPPORT_SUBDIRS += urt
+endif
SUBDIRS = $(PRODUCT_SUBDIRS) $(SUPPORT_SUBDIRS)
--- a/converter/other/Makefile
+++ b/converter/other/Makefile
@@ -7,6 +7,7 @@ VPATH=.:$(SRCDIR)/$(SUBDIR)
include $(BUILDDIR)/config.mk
+ifneq ($(XML2_LIBS),NONE)
TEST_PKGCONFIG_LIBXML2 = if pkg-config libxml-2.0; then echo exists; fi
ifneq ($(shell $(TEST_PKGCONFIG_LIBXML2)),)
@@ -22,6 +23,7 @@ else
XML2_CFLAGS=$(shell xml2-config --cflags)
endif
endif
+endif
SUBDIRS = jbig pnmtopalm jpeg2000 cameratopam pamtosvg
ifneq ($(BUILD_FIASCO), N)
@@ -34,6 +36,7 @@ ifneq ($(TIFFLIB),NONE)
endif
endif
+ifneq ($(PNGLIB),NONE)
TEST_PKGCONFIG_LIBPNG = if pkg-config libpng$(PNGVER); then echo exists; fi
ifneq ($(shell $(TEST_PKGCONFIG_LIBPNG)),)
@@ -58,6 +61,7 @@ else
endif
endif
endif
+endif
ifneq ($(JPEGLIB),NONE)
ifneq ($(JPEGHDR_DIR)x,x)
--- a/other/pamx/Makefile
+++ b/other/pamx/Makefile
@@ -9,6 +9,7 @@ include $(BUILDDIR)/config.mk
EXTERN_INCLUDE =
+ifneq ($(X11LIB),NONE)
ifeq ($(shell pkg-config x11 --modversion --silence-errors),)
# Pkg-config has never heard of X11, or doesn't even exist
@@ -23,6 +24,7 @@ else
X11LIB = $(shell pkg-config x11 --libs)
EXTERN_INCLUDES += $(shell pkg-config x11 --cflags)
endif
+endif
ifeq ($(HAVE_X11LIB),Y)
PORTBINARIES += pamx