You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/x265/files/tests.patch

17 lines
650 B

Tests run against static library (upstream build system):
We build main as both shared & static, main10 & 12 are static only and linked into main.
All need PLATFORM_LIBS, so instruct cmake to also link them.
Index: source/CMakeLists.txt
===================================================================
--- source.orig/CMakeLists.txt
+++ source/CMakeLists.txt
@@ -578,6 +578,7 @@ endif()
if(SVTHEVC_FOUND)
target_link_libraries(x265-static ${SVT_HEVC_LIBRARY})
endif()
+target_link_libraries(x265-static ${PLATFORM_LIBS})
install(TARGETS x265-static
LIBRARY DESTINATION ${LIB_INSTALL_DIR}
ARCHIVE DESTINATION ${LIB_INSTALL_DIR})