You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/apparmor/files/apparmor-3.0.0-makefile.patch

19 lines
653 B

* Avoid installing empty /var/lib/apparmor
* Install rc.apparmor.functions to Gentoo-appropriate location
--- a/Makefile
+++ b/Makefile
@@ -407,10 +407,10 @@
.PHONY: install-indep
install-indep: indep
install -m 755 -d $(INSTALL_CONFDIR)
+ install -m 755 -d ${DESTDIR}/usr/libexec
install -m 644 parser.conf $(INSTALL_CONFDIR)
- install -m 755 -d ${DESTDIR}/var/lib/apparmor
install -m 755 -d $(APPARMOR_BIN_PREFIX)
- install -m 755 rc.apparmor.functions $(APPARMOR_BIN_PREFIX)
+ install -m 755 rc.apparmor.functions ${DESTDIR}/usr/libexec
$(MAKE) -C po install NAME=${NAME} DESTDIR=${DESTDIR}
$(MAKE) install_manpages DESTDIR=${DESTDIR}