You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/idle3-tools/files/makefile.patch

23 lines
951 B

--- a/Makefile 2012-01-11 17:18:57.000000000 +0100
+++ b/Makefile 2018-07-09 23:00:04.111252307 +0200
@@ -6,16 +6,15 @@
binprefix =
manprefix = /usr
exec_prefix = $(binprefix)/
-sbindir = $(exec_prefix)sbin
+sbindir = $(exec_prefix)usr/sbin
mandir = $(manprefix)/share/man
oldmandir = $(manprefix)/man
-CC = gcc
+CC ?= gcc
STRIP = strip
-CFLAGS := -g -O2 -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs $(CFLAGS)
+CFLAGS := -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs $(CFLAGS)
-LDFLAGS = -s
#LDFLAGS = -s -static
INSTALL = install
INSTALL_DATA = $(INSTALL) -m 644