You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/pcsc-slb-rf72-drv/files/pcsc-slb-rf72-drv-1.1.0-ope...

33 lines
984 B

From a0822b820d59a53b0aab87cc12c4d1eae2228561 Mon Sep 17 00:00:00 2001
From: Alon Bar-Lev <alon.barlev@gmail.com>
Date: Fri, 17 Jun 2016 18:58:05 +0300
Subject: [PATCH] build: use openct instead of embedded binary ctapi
Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
--- a/Makefile
+++ b/Makefile
@@ -16,7 +16,7 @@ clean:
rm -f test *.o *.lo *.so
lib: $(OBJ)
- $(LD) -G ifdhandler.o lib/libctapi.a -o libslb_rf72.so
+ $(CC) $(LDFLAGS) -shared `${PKG_CONFIG} --libs-only-L libopenct` -lopenctapi ifdhandler.o -o libslb_rf72.so
ifdhandler.o: ifdhandler.h ifdhandler.c
- $(CC) $(CFLAGS) -c ifdhandler.c $(INCLUDES)
+ $(CC) $(CFLAGS) `${PKG_CONFIG} --cflags libopenct` -fPIC -DHAVE_PTHREAD_H -c ifdhandler.c $(INCLUDES)
--- a/ifdhandler.c
+++ b/ifdhandler.c
@@ -29,7 +29,7 @@
#include "pcscdefines.h"
#include "ifdhandler.h"
#include <ctapidefines.h>
-#include <ctapi.h>
+#include <openct/ctapi.h>
#include <ctbcs.h>
#include <stdio.h>
#include <string.h>
--
2.7.3