You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/ucspi-tcp/files/0.88-ar-ranlib.patch

28 lines
545 B

--- a/Makefile
+++ b/Makefile
@@ -394,12 +394,14 @@
) > load
chmod 755 load
+AR ?= ar
+RANLIB ?= ranlib
makelib: \
warn-auto.sh systype
( cat warn-auto.sh; \
echo 'main="$$1"; shift'; \
echo 'rm -f "$$main"'; \
- echo 'ar cr "$$main" $${1+"$$@"}'; \
+ echo '$(AR) cr "$$main" $${1+"$$@"}'; \
case "`cat systype`" in \
sunos-5.*) ;; \
unix_sv*) ;; \
@@ -408,7 +410,7 @@
dgux-*) ;; \
hp-ux-*) ;; \
sco*) ;; \
- *) echo 'ranlib "$$main"' ;; \
+ *) echo '$(RANLIB) "$$main"' ;; \
esac \
) > makelib
chmod 755 makelib