You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-process/numactl/files/numactl-2.0.14-numademo-cfl...

16 lines
501 B

https://bugs.gentoo.org/540856
respect user CFLAGS
--- numactl-2.0.14/Makefile.am
+++ numactl-2.0.14/Makefile.am
@@ -24,7 +24,7 @@
numademo_SOURCES = numademo.c stream_lib.c stream_lib.h mt.c mt.h clearcache.c clearcache.h
numademo_CPPFLAGS = $(AM_CPPFLAGS) -DHAVE_STREAM_LIB -DHAVE_MT -DHAVE_CLEAR_CACHE
-numademo_CFLAGS = $(AM_CFLAGS) -O3 -ffast-math -funroll-loops
+numademo_CFLAGS = $(AM_CFLAGS) -ffast-math -funroll-loops
if HAVE_TREE_VECTORIZE
numademo_CFLAGS += -ftree-vectorize
endif