You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/vsound/files/vsound-0.6-fix-build-system...

29 lines
541 B

--- a/configure.in
+++ b/configure.in
@@ -3,7 +3,9 @@
AC_CANONICAL_SYSTEM
AM_INIT_AUTOMAKE(vsound, 0.5)
-AM_CONFIG_HEADER(config.h)
+AC_CONFIG_HEADERS(config.h)
+
+AC_CONFIG_MACRO_DIR([.])
AC_PROG_CC
AC_PROG_CPP
@@ -45,12 +47,12 @@
fi
if test "$ac_cv_prog_gcc" = yes ; then
- CFLAGS="-g -O2 -Wall -Wstrict-prototypes -pipe"
+ CFLAGS+=" -Wall -Wstrict-prototypes"
fi
if test "$ac_arg_debug" = yes; then
echo "enabling debug"
- CFLAGS="$CFLAGS -DENABLE_DEBUG "
+ CPPFLAGS+=" -DENABLE_DEBUG"
fi
AC_OUTPUT(Makefile vsound)