You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/vdr/files/vdr-1.6.0_p2_linguas.diff

25 lines
937 B

install only the given value in LINGUAS
signed-of: Joerg Bornkessel <hd_brummy@gentoo.org> ( 2012/04/15 )
diff -Naur vdr-1.7.27.orig/Makefile vdr-1.7.27/Makefile
--- vdr-1.7.27.orig/Makefile 2012-04-15 15:45:18.000000000 +0200
+++ vdr-1.7.27/Makefile 2012-04-15 15:46:21.000000000 +0200
@@ -144,7 +144,7 @@
PODIR = po
LOCALEDIR = locale
-I18Npo = $(wildcard $(PODIR)/*.po)
+I18Npo = $(foreach dir,$(LINGUAS),$(wildcard $(PODIR)/$(dir)*.po))
I18Nmsgs = $(addprefix $(LOCALEDIR)/, $(addsuffix /LC_MESSAGES/vdr.mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
I18Npot = $(PODIR)/vdr.pot
@@ -167,7 +167,7 @@
install-i18n:
@mkdir -p $(DESTDIR)$(LOCDIR)
- @(cd $(LOCALEDIR); cp -r --parents * $(DESTDIR)$(LOCDIR))
+ @(cd $(LOCALEDIR); for linguas in $(LINGUAS); do [ "$$linguas" = "en" ] && continue; cp -r --parents $$linguas* $(DESTDIR)$(LOCDIR); done)
# The 'include' directory (for plugins):