You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/amarok/files/amarok-2.8.0-mysqld-rpath.p...

13 lines
602 B

--- src/core-impl/collections/db/sql/mysqlecollection/CMakeLists.txt.orig 2014-06-15 18:31:07.362415065 -0400
+++ src/core-impl/collections/db/sql/mysqlecollection/CMakeLists.txt 2014-06-15 18:33:19.612419882 -0400
@@ -28,6 +28,9 @@
${ZLIB_LIBRARIES}
)
+SET_TARGET_PROPERTIES(amarok_collection-mysqlecollection PROPERTIES BUILD_WITH_INSTALL_RPATH TRUE)
+SET_TARGET_PROPERTIES(amarok_collection-mysqlecollection PROPERTIES INSTALL_RPATH "${MYSQLD_DIR}")
+
if(NOT WIN32 AND NOT APPLE)
target_link_libraries( amarok_collection-mysqlecollection crypt pthread )
endif(NOT WIN32 AND NOT APPLE)