You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/tracker-miners/files/2.1.5-seccomp.patch

43 lines
1.1 KiB

From b2d4b05a0c9e34b88aaf55b9f52497b07af8e862 Mon Sep 17 00:00:00 2001
From: Mart Raudsepp <leio@gentoo.org>
Date: Fri, 15 Feb 2019 21:11:29 +0200
Subject: [PATCH] build: Only require seccomp when the CPU architecture
supports it
---
meson.build | 18 +++++++++++++++++-
1 file changed, 17 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index ef48e77a6..65ad19cad 100644
--- a/meson.build
+++ b/meson.build
@@ -261,7 +261,23 @@ endif
# Check for libseccomp
##################################################################
-if not libseccomp.found() and host_machine.system() == 'linux'
+host_system = host_machine.system()
+host_cpu = host_machine.cpu()
+unsupported_cpus = [
+ 'alpha',
+ 'ia64',
+ 'm68k',
+ 'parisc',
+ 'parisc64',
+ 'sh4',
+ 'sparc',
+ 'sparc64',
+]
+system_supports_seccomp = host_system == 'linux'
+cpu_supports_seccomp = not unsupported_cpus.contains(host_cpu)
+seccomp_required = system_supports_seccomp and cpu_supports_seccomp
+
+if not libseccomp.found() and seccomp_required
error('Libseccomp is mandatory for sandboxed metadata extraction')
endif
--
2.17.0