You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-lang/mujs/files/mujs-1.0.5-flags.patch

31 lines
839 B

--- a/Makefile 2018-09-11 12:47:31.000000000 +0200
+++ b/Makefile 2018-10-28 20:09:17.000000000 +0100
@@ -15,7 +15,7 @@
# Compiler flags for various configurations:
-CFLAGS := -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
+CFLAGS += -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
ifeq "$(CC)" "clang"
CFLAGS += -Wunreachable-code
@@ -30,9 +30,6 @@
else ifeq "$(build)" "sanitize"
CFLAGS += -pipe -g -fsanitize=address -fno-omit-frame-pointer
LDFLAGS += -fsanitize=address
-else
- CFLAGS += -Os
- LDFLAGS += -Wl,-s
endif
ifeq "$(HAVE_READLINE)" "yes"
@@ -78,7 +75,7 @@
$(OUT)/libmujs.so: one.c $(HDRS)
@ mkdir -p $(dir $@)
- $(CC) $(CFLAGS) -fPIC -shared -o $@ $< -lm
+ $(CC) $(CFLAGS) $(LDFLAGS) -fPIC -shared -o $@ $< -lm
$(OUT)/mujs: $(OUT)/libmujs.o $(OUT)/main.o
@ mkdir -p $(dir $@)