You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/clementine/files/clementine-1.3_rc1-cmake.patch

33 lines
1.1 KiB

--- Clementine-1.3rc1/CMakeLists.txt
+++ Clementine-1.3rc1/CMakeLists.txt
@@ -60,7 +60,7 @@
pkg_check_modules(CDIO libcdio)
pkg_check_modules(CHROMAPRINT REQUIRED libchromaprint)
-pkg_search_module(CRYPTOPP cryptopp libcrypto++)
+#pkg_search_module(CRYPTOPP cryptopp libcrypto++)
pkg_check_modules(GIO gio-2.0)
pkg_check_modules(GLIB REQUIRED glib-2.0)
pkg_check_modules(GOBJECT REQUIRED gobject-2.0)
@@ -275,13 +275,14 @@
optional_component(VISUALISATIONS ON "Visualisations")
-if(NOT HAVE_SPOTIFY_BLOB AND NOT CRYPTOPP_FOUND)
- message(FATAL_ERROR "Either crypto++ must be available or the non-GPL Spotify "
- "code must be compiled in")
-elseif(CRYPTOPP_FOUND)
+#if(NOT HAVE_SPOTIFY_BLOB AND NOT CRYPTOPP_FOUND)
+# message(FATAL_ERROR "Either crypto++ must be available or the non-GPL Spotify "
+# "code must be compiled in")
+#elseif(CRYPTOPP_FOUND)
set(HAVE_CRYPTOPP ON)
- set(HAVE_SPOTIFY_DOWNLOADER ON)
-endif()
+ set(HAVE_SPOTIFY_DOWNLOADER OFF)
+ set(HAVE_SPOTIFY_BLOB OFF)
+#endif()
# Find DBus if it's enabled
if (HAVE_DBUS)