You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/nmap/files/nmap-6.01-make.patch

21 lines
571 B

--- a/Makefile.in
+++ b/Makefile.in
@@ -119,6 +119,8 @@
rm -f $@
$(CXX) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+$(NBASEDIR)/libnbase.a: nbase_build
+
build-%: %/Makefile
cd $* && $(MAKE)
@@ -152,7 +154,7 @@
liblinear_build: $(LIBLINEARDIR)/Makefile
@echo Compiling liblinear; cd $(LIBLINEARDIR) && $(MAKE) liblinear.a CC="$(CC)" CXX="$(CXX)" CFLAGS="$(CFLAGS)"
-build-nmap-update: nmap-update/default_channel.h
+build-nmap-update: nbase_build nmap-update/default_channel.h
#$(LIBPCAPDIR)/Makefile:
# @echo Configuring libpcap; cd $(LIBPCAPDIR); ./configure