You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-wireless/wavemon/files/wavemon-0.7.6-ncurses-tinfo...

20 lines
669 B

--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,7 @@
AC_PROG_CC
AC_PROG_CPP
AC_PROG_INSTALL
+PKG_PROG_PKG_CONFIG
# Checks for header files.
AC_HEADER_STDC
@@ -52,7 +53,7 @@
# Tests involving libraries
AC_CHECK_LIB([m], [pow], [], [AC_MSG_ERROR(math library not found)])
-AC_CHECK_LIB([ncurses], [waddstr], [], [AC_MSG_ERROR(ncurses library not found)])
+PKG_CHECK_MODULES([ncurses], [ncurses], [LIBS="$LIBS $ncurses_LIBS"], AC_MSG_ERROR([ncurses is required but was not found]))
AC_CHECK_LIB([pthread], [pthread_create], [CFLAGS="$CFLAGS -pthread"],
[AC_MSG_ERROR(pthread library not found)])
AC_CHECK_LIB([cap], [cap_get_flag])