You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/srm/files/srm-1.2.11-cflags.patch

24 lines
572 B

--- configure.in 2010-06-06 13:22:08.000000000 -0400
+++ configure.in 2011-11-06 11:36:37.684800151 -0500
@@ -6,8 +6,6 @@
dnl Checks for programs.
AC_PROG_CC
-dnl reset CFLAGS
-CFLAGS=
AC_PROG_INSTALL
AC_PROG_RANLIB
@@ -39,10 +37,9 @@
AC_ARG_ENABLE(debug, [ --enable-debug=[no/yes] turn on debugging
[default=$debug_default]],, enable_debug=$debug_default)
if test "x$enable_debug" = "xyes"; then
- CFLAGS="$CFLAGS -g"
AC_MSG_RESULT(yes)
else
- CFLAGS="$CFLAGS -O2 -DNDEBUG"
+ CFLAGS="$CFLAGS -DNDEBUG"
AC_MSG_RESULT(no)
fi