You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-text/dictd/files/dictd-1.12.0-build.patch

23 lines
643 B

don't force -static so we get both pic and non-pic objects
https://bugs.gentoo.org/342669
--- a/Makefile.in
+++ b/Makefile.in
@@ -117,12 +117,12 @@
@SET_MAKE@
%.o: %.c
- $(LIBTOOL) --tag=CC --mode=compile $(CC) -c $(CFLAGS) $< -o $@
+ $(LIBTOOL) --tag=CC --mode=compile $(CC) -c $(CFLAGS) $< -o $@ -static
%.o: %.cpp
- $(LIBTOOL) --tag=CXX --mode=compile $(CXX) -c $(CFLAGS) $< -o $@
+ $(LIBTOOL) --tag=CXX --mode=compile $(CXX) -c $(CFLAGS) $< -o $@ -static
%: %.o
- $(LIBTOOL) --tag=CC --mode=link $(CC) -o $@ -static \
+ $(LIBTOOL) --tag=CC --mode=link $(CC) -o $@ \
$^ $(OBJS) $(LDFLAGS) -lz ${LIBS}
include $(srcdir)/deps