You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/kdelibs4support/files/kdelibs4support-5.82.0-unus...

52 lines
1.7 KiB

From b51d32df6a89e559871469178de1c6fd8c8a2882 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <asturm@gentoo.org>
Date: Sun, 22 Nov 2020 00:27:55 +0100
Subject: [PATCH 2/2] Drop Qt5Designer dependency
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
---
CMakeLists.txt | 2 +-
cmake/modules/ECMQt4To5Porting.cmake | 1 -
cmake/modules/FindQt5Transitional.cmake | 1 -
3 files changed, 1 insertion(+), 3 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a432591..e503999d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,7 +20,7 @@ include(GenerateExportHeader)
include(CMakeFindFrameworks)
set(REQUIRED_QT_VERSION 5.15.0)
-find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Network Widgets DBus Test Svg PrintSupport Designer)
+find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Network Widgets DBus Test Svg PrintSupport)
find_package(KF5Completion ${KF_DEP_VERSION} REQUIRED)
find_package(KF5Config ${KF_DEP_VERSION} REQUIRED)
diff --git a/cmake/modules/ECMQt4To5Porting.cmake b/cmake/modules/ECMQt4To5Porting.cmake
index 4204fa54..01b8f995 100644
--- a/cmake/modules/ECMQt4To5Porting.cmake
+++ b/cmake/modules/ECMQt4To5Porting.cmake
@@ -160,7 +160,6 @@ set(_qt_modules
DBus
Network
Test
- Designer
Concurrent
Xml
UiTools
diff --git a/cmake/modules/FindQt5Transitional.cmake b/cmake/modules/FindQt5Transitional.cmake
index df354fc6..68fa6d47 100644
--- a/cmake/modules/FindQt5Transitional.cmake
+++ b/cmake/modules/FindQt5Transitional.cmake
@@ -6,7 +6,6 @@ if (Qt5Core_FOUND)
Core
Gui
DBus
- Designer
Declarative
Script
ScriptTools
--
2.30.0