You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/clblas/files/clblas-2.12-disable-multili...

27 lines
1.1 KiB

Description: disable multilib flags
Author: Ghislain Antony Vaillant <ghisvail@gmail.com>
Forwarded: not-needed
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -305,18 +305,6 @@
# Don't use -rpath.
set(CMAKE_SKIP_RPATH ON CACHE BOOL "Skip RPATH" FORCE)
- # Need to determine the target machine of the C compiler, because
- # the '-m32' and '-m64' flags are supported on x86 but not on e.g. ARM.
- exec_program( "${CMAKE_C_COMPILER} -dumpmachine"
- OUTPUT_VARIABLE CMAKE_C_COMPILER_MACHINE )
- message( STATUS "CMAKE_C_COMPILER_MACHINE: ${CMAKE_C_COMPILER_MACHINE}" )
- # The "86" regular expression matches x86, x86_64, i686, etc.
- if(${CMAKE_C_COMPILER_MACHINE} MATCHES "86")
- set(CMAKE_C_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_C_FLAGS}")
- set(CMAKE_CXX_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_CXX_FLAGS}")
- set(CMAKE_Fortran_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_Fortran_FLAGS}")
- endif()
-
if(TARGET_PLATFORM EQUAL 32)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fno-builtin")
endif()