You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/flann/files/flann-1.9.1-cmake-3.11-1.patch

12 lines
663 B

--- a/src/cpp/CMakeLists.txt 2019-02-14 21:58:41.567625108 +0100
+++ b/src/cpp/CMakeLists.txt 2019-02-14 21:59:04.017920926 +0100
@@ -34,7 +34,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux" AN
target_link_libraries(flann_cpp -Wl,-whole-archive flann_cpp_s -Wl,-no-whole-archive)
if (BUILD_CUDA_LIB)
- cuda_add_library(flann_cuda SHARED "")
+ cuda_add_library(flann_cuda SHARED "empty.cpp")
set_target_properties(flann_cuda PROPERTIES LINKER_LANGUAGE CXX)
target_link_libraries(flann_cuda -Wl,-whole-archive flann_cuda_s -Wl,-no-whole-archive)
set_property(TARGET flann_cpp_s PROPERTY COMPILE_DEFINITIONS FLANN_USE_CUDA)